FXOpen News - MT4 versions below 500 will not be supported as from August 1, 2013

FXOpen recommends traders to update the trading platform MT4 in connection with the release of a new version of MT4 platform components. The latest version № 507 provides traders with such new abilities as quick registration of trading signals, setting the spread during testing and others. 

 The latest MT4 update also includes different corrections of several major and many minor bugs. You can download the trading platform MT4 right now in order to test the new version along with its’ new features and improvements. 

Attention! Since August, 1 2013 desktop client terminals of versions less than 500 will be no longer supported (not applied to mobile terminals). With regard to that fact we recommend all traders to update their trading terminals to the latest available version. 

Download a new version of MT4 for ECN
Download a new version of MT4 

Best regards,
FXOpen NZ Limited
Customer Service
E-mail: support@fxopen.com
FXOpen Live Chat (24/5)

No comments:

Post a Comment